Updateproblem mit dem Paket gstreamer0.10-good-plugins

Ich hatte heute ein Problem beim updaten von Manjaro. Paketabhängigkeiten konnten nicht aufgelöst werden.

[andi@pc ~]$ sudo pacman -Syu
[sudo] Passwort für andi:
:: Synchronisiere Paketdatenbanken…
core ist aktuell
extra ist aktuell
community ist aktuell
multilib ist aktuell
:: Starte vollständige Systemaktualisierung…
Warnung: menulibre: Lokale Version (1:2.1.0-1) ist neuer als community (2.1.3-2)
Löse Abhängigkeiten auf…
Suche nach in Konflikt stehenden Paketen…
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: gstreamer0.10-good-plugins: das Installieren von libsoup (2.58.1-1) löscht ein benötigtes Packet von ‚libsoup-gnome‘

Ich deinstallierte das Paket gstreamer0.10-good-plugins.

sudo pacman -R gstreamer0.10-good-plugins

Nun lief das Update durch.

sudo pacman -Syu

Den Pacman Cache leeren

Im November hatte ich meine Root-Partition auf 20GB vergrößert. Nun ist die Partition schon wieder um 4GB größer geworden, ohne das neue Installationen hinzukamen.
Es galt nicht mehr benötigte und veraltete Pakete aus (/var/cache/pacman/pkg) zu entfernen. Einen Überblick verschaffe ich mir mit:

du -sh /var/cache/pacman/pkg

Nun entferne ich die nicht mehr benötigten gecachten Pakete.

sudo pacman -Sc

Löscht nicht mehr benötigte und veraltete Pakete

Pacman -Sc


Nun ist meine Root-Partition nur noch mit 7GB belegt.

In Manjaro den Adobe Flash Player deinstallieren

In Linux Manjaro sind sehr viele Programme vorinstalliert. So auch der Adobe Flash Player. Von diesem entledige ich mich sofort nach der Installation von Manjaro.

sudo pacman -R flashplugin

Der Adobe Flash Player wird in Zeiten von HTML5 nicht mehr benötigt und stellt nur noch ein Sicherheitsrisiko für meinen Computer da.