Updateproblem mit dem Paket gstreamer0.10-good-plugins

Ich hatte heute ein Problem beim updaten von Manjaro. Paketabhängigkeiten konnten nicht aufgelöst werden.

[andi@pc ~]$ sudo pacman -Syu
[sudo] Passwort für andi:
:: Synchronisiere Paketdatenbanken…
core ist aktuell
extra ist aktuell
community ist aktuell
multilib ist aktuell
:: Starte vollständige Systemaktualisierung…
Warnung: menulibre: Lokale Version (1:2.1.0-1) ist neuer als community (2.1.3-2)
Löse Abhängigkeiten auf…
Suche nach in Konflikt stehenden Paketen…
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: gstreamer0.10-good-plugins: das Installieren von libsoup (2.58.1-1) löscht ein benötigtes Packet von ‚libsoup-gnome‘

Ich deinstallierte das Paket gstreamer0.10-good-plugins.

sudo pacman -R gstreamer0.10-good-plugins

Nun lief das Update durch.

sudo pacman -Syu

Manjaro Installation schlägt fehl

Mit dem .iso manjaro_xfce-17.0.1-stable-x86_64.iso klappt bei mir keine Installation von Linux Manjaro.
Nach dem booten von Manjaro von dem benannten Image, erblickte ich einen neuen Installer. Ich war guter Dinge.
Im ersten Installationsversuch stürzte der Installer ab. Bei weiteren Versuchen mit vorpartitionierter Platte trat keine Besserung ein. Meine weiteren Installationsversuche scheiterten daran, dass der Bootloader nicht auf die Festplatte geschrieben werden konnte.

Ich weiß noch nicht, wann ich Manjaro mit neuer ISO-Version testen werde.
Ich bevorzuge zur Zeit Arch Linux:

In Manjaro den Adobe Flash Player deinstallieren

In Linux Manjaro sind sehr viele Programme vorinstalliert. So auch der Adobe Flash Player. Von diesem entledige ich mich sofort nach der Installation von Manjaro.

sudo pacman -R flashplugin

Der Adobe Flash Player wird in Zeiten von HTML5 nicht mehr benötigt und stellt nur noch ein Sicherheitsrisiko für meinen Computer da.

Garmin eTrex Legend HCx und Manjaro

Garmin eTrex Legend mit OSM-Karte
Ich habe lange Zeit mein Garmin eTrex Legend HCx nicht benutzt. Jetzt habe ich das Problem, dass ich keine Wegpunkte ex- und importiert bekomme. Die Pakete gebabbel, gpsbabel und gpsd habe ich installiert. Bei einem Kollegen funktioniert es so mit Arch Linux.

Ich habe es mit und ohne udev-Regel probiert die Daten aufs Gerät zu laden.
/etc/udev/rules.d/51-garmin.rules

ATTRS{idVendor}=="091e", ATTRS{idProduct}=="0003", MODE="0666", GROUP="users"

Wenn ich einen Befehl mit gpsbabel oder Gebabbel absetze antwortet das Garmin nicht. Mit Rootrechten besteht der gleiche Fehler.
Die Ausgabe von gpsbabel:

gpsbabel -D 5 -w -i garmin -f /dev/ttyUSB0 -o gpx -F gps.gpx
GPSBabel Version: 1.5.3 
GPS Serial Open at 9600
Tx Data:10 fe 00 02 10 03 : ...(PRDREQ  )
Rx Data:10 06 02 fe 00 fa 10 03  .. (ACK     )
[ERROR] GPS_Packet_Read: Timeout.  No data received.
GARMIN:Can't init /dev/ttyUSB0

Habt ihr eine Idee wo das Problem liegen könnte?

Eine plötzliche Tonstörung in Manjaro

Gestern wollte ich an meinem Desktop-Rechner Musik per Headset hören. Es kam kein Ton aus dem Kopfhörer. Ich stellte in den Lautsprechereinstellungen fest, dass das Headset gemutet ist.

Lautstäkeregler (Alsa mixer)

Lautstäkeregler


Ich tätigte die entsprechenden Einstellungen im Lautsprecherregler und es kam Musik aus dem Headset.
Danach nahm ich noch Einstellungen im Hauptregler vor. Dann kam es zu einem knacken und der Ton aus Lautsprecher und Headset verstummte. Ich öffnete den PulseAudio-Lautsprecherregler.
PulseAudio Einstellungen

PulseAudio-Lautstärkeregler


Auch hier waren alle Einstellungen korrekt. Jetzt öffnete ich den AlsaMixer im Terminal.
AlsaMixer im Terminal

AlsaMixer


Hier waren auch alle Einstellungen richtig. Nur der Ton wollte immer noch nicht.
Ich überlegte die zuvor gespeicherte Lautstärke mit einem Befehl wieder herzustellen.

alsactl restore


alsactl restore
alsactl: state_lock:125: file /var/lib/alsa/asound.state lock error: File exists
alsactl: load_state:1683: Cannot open /var/lib/alsa/asound.state for reading: File exists
alsactl: sysfs_init:48: sysfs path '/sys' is invalid

Found hardware: "HDA-Intel" "Realtek ALC892" "HDA:10ec0892,18497892,00100302 HDA:80862806,80860101,00100000" "0x1849" "0x7892"
Hardware is initialized using a generic method
alsactl: sysfs_init:48: sysfs path '/sys' is invalid

Found hardware: "HDA-Intel" "Nvidia GPU 60 HDMI/DP" "HDA:10de0060,104384bb,00100100" "0x1043" "0x84bb"
Hardware is initialized using a generic method

Der Ton geht immer noch nicht. Andere Benutzer an diesem Rechner haben Ton. Jetzt sind nur die Audio-Einstellungen in meinem /home verbastelt. Ich weiß nicht was ich noch tun kann. Habt ihr eine Idee was ich noch machen kann?

Update

Nach 3 Tagen und einigen Neustarts ging der Ton plötzlich wieder.

Brother MFC-J4620DW und Manjaro

Ich habe den Multifunktionsdrucker Brother MFC-J4620DW. Auf der Firmenwebseite von Brother gibt es Treiber für Debian-basierte Systeme.
Für Manjaro habe ich den entsprechenden Treiber im AUR gefunden. Und daraus installiere ich den Treiber.

yaourt -S brother-mfc-j4620dw

Es wird ein Dialog abgefragt, bei dem man JA oder Nein auswählen kann. Die Sache ist selbsterklärend bei der Ausführung.
Nach der Treiber-Installation starte ich den CUPS-Dienst neu.

systemctl restart org.cups.cupsd

Nun kann der Drucker über CUPS oder die Druckereinstellungen hinzugefügt werden.

Druckereinstellungen Brother MFC-J4620DW

Brother MFC-J4620DW

Einen neuen Benutzer anlegen

Auf meinem neuen Manjaro-System wollte ich einen neuen Benutzer anlegen. Ich stellte fest, dass die Befehle adduser und deluser nicht zur Verfügung stehen. Statt dessen benutzt man useradd zum Anlegen eines Users und zum Löschen userdel.

Ich habe einen neuen Benutzer mit useradd benutzername angelegt. Dieser konnte sich aber nicht einloggen und landete immer wieder im Anmeldebildschirm. Es wurde kein /home Verzeichniss für diesen Benutzer angelegt. Der Befehl muss also mit weiteren Parametern ausgeführt werden.

sudo useradd -m -g users -s /bin/bash benutzername

Danach kann das Passwort vergeben werden.

sudo passwd benutzername